ΚΟΙΝΩΝΙΑ
12/06/2019 16:11 EEST

Πανελλήνιες 2019: Δείτε τις απαντήσεις του ΑΕΠΠ από το Φροντιστήριο «Παναγιωτόπουλος - Καλλίγας»

Και των υπόλοιπων μαθημάτων προσανατολισμού.

Σε μαθήματα προσανατολισμού εξετάστηκαν οι υποψήφιοι των ΓΕΛ για την εισαγωγή στην Τριτοβάθμια Εκπαίδευση. Ειδικότερα, οι υποψήφιοι της Ομάδας Προσανατολισμού Ανθρωπιστικών Σπουδών εξετάστηκαν στην Ιστορία, οι υποψήφιοι της ΟΠ Θετικών Σπουδών στη Φυσική και οι υποψήφιοι της ΟΠ Σπουδών Οικονομίας και Πληροφορικής, στο μάθημα Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον.

Δείτε τα θέματα του ΑΕΠΠ:

 

ΘΕΜΑ 1

 

Α1)

1. ΣΩΣΤΟ

2. ΛΑΘΟΣ

3. ΛΑΘΟΣ

4. ΣΩΣΤΟ

5. ΛΑΘΟΣ

 

Α2) Αναζήτηση (searching), κατά την οποία προσπελαύνονται οι κόμβοι μιας δομής, προκειμένου να εντοπιστούν ένας ή περισσότεροι που έχουν μια δεδομένη ιδιότητα.

Ταξινόμηση (sorting), όπου οι κόμβοι μιας δομής διατάσσονται κατά αύξουσα ή φθίνουσα σειρά.

Συγχώνευση (merging), κατά την οποία δύο ή περισσότερες δομές συνενώνονται σε μία ενιαία δομή.

Αντιγραφή (copying), κατά την οποία όλοι οι κόμβοι ή μερικοί από τους κόμβους μίας δομής αντιγράφονται σε μία άλλη δομή.

 

 

Α3) ΕΜΦΑΝΙΖΕΙ :

 

α) 6

8

10

 

β) 7

 

γ) 1

3

Α4)

 

 

α) ΟΣΟ

β) ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Α5)

 

Ρ ← 0

ΟΣΟΜ2 > 0 ΕΠΑΝΑΛΑΒΕ

ΑΝΜ2 MOD 2 = 1 ΤΟΤΕ

ΡΡ + Μ1

ΤΕΛΟΣ_ΑΝ

Μ1 ← Μ1 * 2

Μ2 ← Μ2 DIV 2

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ Ρ

 

ΘΕΜΑ 2

 

Β1:

 

(1) 0

(2) n

(3) ΨΕΥΔΗΣ

(4) i

(5) count + 1

(6) 3

(7) ΑΛΗΘΗΣ

(8) position

(9) i + 1

(10) done = ΑΛΗΘΗΣ

 

 

Β2)

 

α)

 

1) Η δεύτερη πραγματική παραμετρος πρέπει να είναι πίνακας χαρακτήτων

 

2) Η συνάρτηση δεν καλείται με ΚΑΛΕΣΕ

 

3) Η διαδικασία Β έχει 3 τυπικές παραμέτρους, καλείται με 2 πραγματικές

 

4) Η συνάρτηση Α επιστρέφει πραγματικό, αλλά στο πρόγραμμα εκχωρείται στο υ που έχει δηλωθεί στους χαρακτήρες

 

5) Η διαδικασία Β πρέπει να κληθεί με την εντολή ΚΑΛΕΣΕ και όχι με εκχώρηση τιμής στο κ.

 

β)

 

1) π ← Α(κ,θ)

 

2) γ ← Α(μ,θ)

 

3) ΚΑΛΕΣΕ Β(π,μ,γ)

 

4) π ← Α(μ,θ)

 

5) ΚΑΛΕΣΕ Β(π, μ, Ρ[1])

 

ΘΕΜΑ 3

 

ΠΡΟΓΡΑΜΜΑ video

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: πλήθος1,πλήθος2,πλήθος3,max,max2,αριθ

ΧΑΡΑΚΤΗΡΕΣ: On_Max,On_Max2,τίτλος

ΑΡΧΗ

πλήθος1 0

πλήθος2 0

πλήθος3 0

max 0

ΔΙΑΒΑΣΕ τίτλος

ΟΣΟ τίτλος <> ‘ΤΕΛΟΣ’ ΕΠΑΝΑΛΑΒΕ

ΔΙΑΒΑΣΕ αριθ

ΟΣΟ αριθ < 0 ΕΠΑΝΑΛΑΒΕ

ΓΡΑΨΕ ‘Λάθος, πληκτρολογήστε πάλι’

ΔΙΑΒΑΣΕ τίτλος

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ αριθ > max ΤΟΤΕ

max αριθ

On_Max τίτλος

ΤΕΛΟΣ_ΑΝ

ΑΝ αριθ=0 ΤΟΤΕ

ΓΡΑΨΕ ‘...’

ΑΛΛΙΩΣ_ΑΝ αριθ <= 100 ΤΟΤΕ

πλήθος1 πλήθος1 + 1

ΑΛΛΙΩΣ_ΑΝ αριθ <= 1000 ΤΟΤΕ

πλήθος2 πλήθος2 + 1

ΑΛΛΙΩΣ

πλήθος3 πλήθος3 + 1

ΤΕΛΟΣ_ΑΝ

ΔΙΑΒΑΣΕ τίτλος

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ‘Χαμηλη κατηγορία :’, πλήθος1

ΓΡΑΨΕ ‘Μεσαία κατηγορία :’, πλήθος2

ΓΡΑΨΕ ‘Υψηλή κατηγορία :’, πλήθος3

max2 πλήθος1

On_Max2 ‘Χαμηλη ’

ΑΝ πλήθος2 > max2 ΤΟΤΕ

max2 πλήθος2

On_Max2 ‘Μεσαία ’

ΤΕΛΟΣ_ΑΝ

ΑΝ πλήθος3 > max2 ΤΟΤΕ

max2 πλήθος3

On_Max2 ‘Υψηλή ’

ΤΕΛΟΣ_ΑΝ

ΓΡΑΨΕ ‘Τα περισσότερα βίντεο είχε,’

ΓΡΑΨΕ ‘η κατηγορία’,On_Max2

ΓΡΑΨΕ ‘Την μεγαλύτερη επισκεψιμότητα είχε’

ΓΡΑΨΕ ‘Ο τίτλος’,On_Max

 

 

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

 

ΘΕΜΑ 4

ΠΡΟΓΡΑΜΜΑ βαλκανιαδα

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: i,j,ΒΑΘ[40,6],ΒΑΘκωδ,προβ,βαθμός,απαντ,tempΣ,ΣΒ[40]

ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[40],tempΟ,απαντ

ΑΡΧΗ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 40

ΔΙΑΒΑΣΕ ΟΝ[i]

ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6

ΒΑΘ[i,j] 0

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

ΔΙΑΒΑΣΕ κωδ, προβ, βαθμός

ΑΝ ( βαθμός > ΒΑΘ[κωδ, προβ] ) ΤΟΤΕ

ΒΑΘ[κωδ, προβ] βαθμός

ΤΕΛΟΣ_ΑΝ

ΓΡΑΨΕ ‘Υπάρχει νεα λύση προβλήματος; ΝΑΙ/ΟΧΙ’

ΔΙΑΒΑΣΕ απαντ

ΜΕΧΡΙΣ_ΟΤΟΥ απαντ=‘ΟΧΙ’

ΚΑΛΕΣΕ ΥΣΒ(ΒΑΘ,ΣΒ)

ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 40

ΓΙΑ j ΑΠΟ 40 ΜΕΧΡΙ i ΜΕ_ΒΗΜΑ -1

ΑΝ ΣΒ[j-1] < ΣΒ[j] ΤΟΤΕ

tempΣ ΣΒ[j-1]

ΣΒ[j-1] ΣΒ[j]

ΣΒ[j] tempΣ

tempΟ ΟΝ[j-1]

ΟΝ[j-1] ΟΝ[j]

ΟΝ[j] tempΟ

ΤΕΛΟΣ_ΑΝ

ΑΝ ΣΒ[j-1] = ΣΒ[j] ΤΟΤΕ

ΑΝ ΟΝ[j-1] > ΟΝ[j] ΤΟΤΕ

tempΟ ΟΝ[j-1]

ΟΝ[j-1] ΟΝ[j]

ΟΝ[j] tempΟ

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 40

ΓΡΑΨΕ ΟΝ[i]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

ΔΙΑΔΙΚΑΣΙΑ ΥΣΒ(ΒΑΘ,ΣΒ)

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ:i,j,ΣΒ[40],ΒΑΘ[40,6]

ΑΡΧΗ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 40

ΣΒ[i] 0

ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6

ΣΒ[i] ΣΒ[i] + ΒΑΘ[i,j]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ